The Domain Name System (DNS), is a hierarchical, distributed database that translates names to numeric addresses. Questions involving publicly accessible domains should include the real, Fully Qualified Domain Name (FQDN)
DNS is the Domain Name System, a hierarchical, distributed database where the keys are domain names. It translates names to numeric addresses The primary references are:
- RFC 1034 - Domain Names - Concepts and Facilities
- RFC 1035 - Domain Names - Implementation and Specification
These documents collectively form STD 13. RFC 2181 is a frequently cited reference for STD 13 that addresses some of the more confusing areas of operation.
The most common record types found in the DNS are:
- "A" records - the mapping from a domain name to an IPv4 address
- "AAAA" records - the mapping from a domain name to an IPv6 address
- "MX" records - the mapping from a domain name to the host name of an SMTP server
- "NS" records - used to delegate a portion of the hierarchy to specific DNS servers
- "PTR" records - typically used (via
in-addr.arpa.) to map an IPv4 address back to a domain name - "CNAME" records - used to alias a domain name to its canonical version
DNS packets are transported over UDP and TCP port 53. UDP is more commonly used, but larger DNS responses and zone transfers require TCP. See RFC 5966. DNS over HTTPS uses port 443.
This Wikipedia article provides an approachable introduction to DNS.